[PATCH] D45118: Linking debug (DWARF) sections from the WebAssembly object files
Yury Delendik via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Apr 16 14:12:22 PDT 2018
yurydelendik marked 8 inline comments as done.
yurydelendik added inline comments.
================
Comment at: wasm/InputFiles.cpp:305
+ }
+ case WASM_SYMBOL_TYPE_SECTION: {
+ if (Sym.Info.SectionCode != WASM_SEC_CUSTOM)
----------------
ruiu wrote:
> Is this a new enum? Looks like it doesn't exist at the moment.
Yes, it is. It will be defined in D44184
================
Comment at: wasm/InputFiles.cpp:46
+static size_t getFunctionSizeLength(const ArrayRef<uint8_t> FunctionBody) {
+ unsigned Count;
----------------
ruiu wrote:
> getSizeLength sounds a odd name. Aren't size and length synonyms?
Renamed to `getFunctionCodeOffset`
Repository:
rLLD LLVM Linker
https://reviews.llvm.org/D45118
More information about the llvm-commits
mailing list