[PATCH] D45018: [ELF] - Improve -Map output.

George Rimar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 29 04:02:51 PDT 2018


grimar created this revision.
grimar added reviewers: ruiu, espindola.
Herald added subscribers: arichardson, emaste.

This patch implements following changes:

- Dynamic size of `Address` and `Size` columns.
- Rename `Address` to `LMA`
- Use right_justify


https://reviews.llvm.org/D45018

Files:
  ELF/MapFile.cpp
  test/ELF/linkerscript/map-file.test
  test/ELF/map-file.s

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D45018.140205.patch
Type: text/x-patch
Size: 12120 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20180329/1467e6f4/attachment.bin>


More information about the llvm-commits mailing list