[PATCH] D44999: Strip @VER suffices from the LTO output

Rafael Avila de Espindola via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 28 15:50:11 PDT 2018


espindola added inline comments.


================
Comment at: ELF/InputFiles.cpp:269
+template <class ELFT> ArrayRef<Symbol *> ObjFile<ELFT>::getGlobalSymbols() {
+  return makeArrayRef(this->Symbols).slice(this->FirstNonLocal);
+}
----------------
ruiu wrote:
> off-topic, but maybe we should rename this FirstGlobal. NonLocal is probably more technically correct, but colloquially Local <-> Global is much easier to digest.
LGTM. We already use global to mean non local in other parts of the linker.


https://reviews.llvm.org/D44999





More information about the llvm-commits mailing list