[PATCH] D41675: Change memcpy/memove/memset to have dest and source alignment attributes.

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jan 2 14:14:58 PST 2018

arsenm added inline comments.

Comment at: lib/IR/AutoUpgrade.cpp:526
+    if (Name.startswith("memcpy.") && F->arg_size() == 5) {
+      F->setName(Name + ".old");
+      // Get the types of dest, src, and len
Is there a point to changing the name to something that will just be deleted?


More information about the llvm-commits mailing list