[PATCH] D41249: test-suite: add avx512 tests with math intrinsics
Matthias Braun via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Dec 14 11:58:43 PST 2017
MatzeB accepted this revision.
MatzeB added a comment.
This revision is now accepted and ready to land.
I didn't really read all the tests in detail, but from a high level this looks fine.
================
Comment at: SingleSource/UnitTests/Vector/AVX512/minmax_shift.c:1150-1156
+ if (n_errs != 0) {
+ printf("FAILED\n");
+ return 1;
+ }
+
+ printf("PASSED\n");
+ return 0;
----------------
This pattern repeats in every test, why not put it into a function?
And to be nitpicky I think printing FAILED/PASSED is unnecessary: In the PASSED case it's perfectly fine to print nothing and return 0 IMO, in the FAILED case you should have already seen an error message anyway.
Repository:
rT test-suite
https://reviews.llvm.org/D41249
More information about the llvm-commits
mailing list