[PATCH] D36704: [CodeGen] Improve the consistency of instruction fusion
Florian Hahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 27 09:01:08 PST 2017
fhahn added inline comments.
================
Comment at: llvm/lib/CodeGen/MacroFusion.cpp:90
+ SUnit *SU = SI.getSUnit();
+ if (SI.isWeak() || (SI.getKind() != SDep::Order && SI.isCtrl()) ||
+ &FirstSU == SU || FirstSU.isSucc(SU))
----------------
Would it make sense to move this code to a function (maybe just a closure in this function? I suspect the fact that we use isPred/isSucc makes things slightly tricky? :(
https://reviews.llvm.org/D36704
More information about the llvm-commits
mailing list