[PATCH] D39259: [lld] unified COFF and ELF error handling on new Common/ErrorHandler
Bob Haarman via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Oct 24 14:16:02 PDT 2017
inglorion added a comment.
Summary of the changes:
- Instead of #include "Error.h", #include "lld/Common/ErrorHandler.h".
- Instead of ColorDiagnostics, ErrorLimit, and FatalWarnings being properties of the Config object, they are now set on the ErrorHandler object.
- Removed the fatal() variants that take Error or std::error_code. This was previously done for ELF, so I've done it here for COFF too.
- Instead of ErrorCount as a global variable, the value is now retrieved by calling the errorCount() function.
I chose ErrorHandler instead of Error as the name of the header file, because there is already an Error.h in lld/Core, and also in LLVM.
https://reviews.llvm.org/D39259
More information about the llvm-commits
mailing list