[PATCH] D38996: [ELF] - Simplify how GC works with MergeInputSection.

George Rimar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 17 04:31:15 PDT 2017


grimar added inline comments.


================
Comment at: ELF/InputSection.h:274
+  // debug ones. Function returns true if pieces should be live by default.
+  bool arePiecesLiveByDefault() {
+    return !Config->GcSections || !(this->Flags & llvm::ELF::SHF_ALLOC);
----------------
I wonder if `shouldGCPieces` would be better name.


https://reviews.llvm.org/D38996





More information about the llvm-commits mailing list