[PATCH] D34956: [ELF] - Store pointer to PT_LOAD instead of pointer to first section (FirstInPtLoad) in OutputSection
George Rimar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Sep 7 03:50:38 PDT 2017
grimar added inline comments.
================
Comment at: ELF/LinkerScript.cpp:773
+ Out::ProgramHeaders->PtLoad = nullptr;
+ FirstPTLoad->First = findFirstSection(FirstPTLoad);
----------------
ruiu wrote:
> `First` is too terse. The member should be renamed `FirstSec` in a follow-up patch.
Will do, thanks for review !
https://reviews.llvm.org/D34956
More information about the llvm-commits
mailing list