[PATCH] D36395: [InstCombine] narrow rotate left/right patterns to eliminate zext/trunc (PR34046)
Craig Topper via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Aug 8 16:59:55 PDT 2017
craig.topper added a comment.
I think I confused myself reading this assert. So the !isa<IntegerType> is for the vector case? Would it be more readable as isa<VectorType>?
assert((!isa<IntegerType>(Trunc.getSrcTy()) ||
shouldChangeType(Trunc.getSrcTy(), Trunc.getType())) &&
"Don't narrow to an illegal type");
m_SpecificInt should work on vectors right?
https://reviews.llvm.org/D36395
More information about the llvm-commits
mailing list