[PATCH] D36260: [ARM] Use searchable-table for banked registers
Florian Hahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Aug 4 02:03:25 PDT 2017
fhahn added inline comments.
================
Comment at: lib/Target/ARM/InstPrinter/ARMInstPrinter.cpp:882
// the ARM ARM v7C, and are all over the shop.
- if (R) {
- O << "SPSR_";
-
- switch (SysM) {
- case 0x0e:
- O << "fiq";
- return;
- case 0x10:
- O << "irq";
- return;
- case 0x12:
- O << "svc";
- return;
- case 0x14:
- O << "abt";
- return;
- case 0x16:
- O << "und";
- return;
- case 0x1c:
- O << "mon";
- return;
- case 0x1e:
- O << "hyp";
- return;
- default:
- llvm_unreachable("Invalid banked SPSR register");
- }
- }
-
- assert(!R && "should have dealt with SPSR regs");
- const char *RegNames[] = {
- "r8_usr", "r9_usr", "r10_usr", "r11_usr", "r12_usr", "sp_usr", "lr_usr",
- "", "r8_fiq", "r9_fiq", "r10_fiq", "r11_fiq", "r12_fiq", "sp_fiq",
- "lr_fiq", "", "lr_irq", "sp_irq", "lr_svc", "sp_svc", "lr_abt",
- "sp_abt", "lr_und", "sp_und", "", "", "", "",
- "lr_mon", "sp_mon", "elr_hyp", "sp_hyp"};
- const char *Name = RegNames[SysM];
- assert(Name[0] && "invalid banked register operand");
-
- O << Name;
+ uint32_t R = (Banked & 0x20) >> 5;
+ if (R)
----------------
Hm maybe we should rename R to isSPSR or something, to make that clearer or just get rid of the variable and move it into the condition (with a comment)
================
Comment at: lib/Target/ARM/InstPrinter/ARMInstPrinter.cpp:885
+ Name.replace(0, 4, "SPSR"); // convert 'spsr_' to 'SPSR_'
+ O << name;
}
----------------
Should this be `Name` (declared on line 878?)
https://reviews.llvm.org/D36260
More information about the llvm-commits
mailing list