[PATCH] D36137: [Polly][Simplify] Rewrite redundant write detection algorithm.
Michael Kruse via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Aug 1 04:25:07 PDT 2017
Meinersbur updated this revision to Diff 109080.
Meinersbur added a comment.
- Rename GuaranteedReads to Known
- Remove whitespace at end of lines
https://reviews.llvm.org/D36137
Files:
lib/Transform/Simplify.cpp
test/Simplify/notredundant_region_loop.ll
test/Simplify/notredundant_region_loop___%for---%return.jscop
test/Simplify/notredundant_region_loop___%for---%return.jscop.transformed
test/Simplify/notredundant_region_middle.ll
test/Simplify/redundant_differentindex.ll
test/Simplify/redundant_partialwrite.ll
test/Simplify/redundant_partialwrite___%for---%return.jscop
test/Simplify/redundant_partialwrite___%for---%return.jscop.transformed
test/Simplify/redundant_region.ll
test/Simplify/redundant_region___%for---%return.jscop
test/Simplify/redundant_region___%for---%return.jscop.transformed
test/Simplify/redundant_region_scalar.ll
test/Simplify/redundant_region_scalar___%for---%return.jscop
test/Simplify/redundant_region_scalar___%for---%return.jscop.transformed
test/Simplify/redundant_storebetween.ll
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D36137.109080.patch
Type: text/x-patch
Size: 30212 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170801/bed95b7b/attachment.bin>
More information about the llvm-commits
mailing list