[PATCH] D35717: AMDGPU: Make areMemAccessesTriviallyDisjoint more aware of segment flat
Stanislav Mekhanoshin via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jul 21 10:56:08 PDT 2017
rampitec added inline comments.
================
Comment at: lib/Target/AMDGPU/SIInstrInfo.h:425
+ // i.e. global_* or scratch_*.
+ static bool isSegmentFLAT(const MachineInstr &MI) {
+ auto Flags = MI.getDesc().TSFlags;
----------------
arsenm wrote:
> rampitec wrote:
> > The name is confusing. Flat segments covers all other segments, so it is always a flat segment.
> The FLAT refers only the the encoding. It's a segment specific flat
isSegmentSpecificFLAT() maybe?
https://reviews.llvm.org/D35717
More information about the llvm-commits
mailing list