[PATCH] D34726: AMDGPU/SI: Do not insert an instruction into worklist twice in movetovalu

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 13 14:25:33 PDT 2017


arsenm accepted this revision.
arsenm added a comment.
This revision is now accepted and ready to land.

LGTM



================
Comment at: lib/Target/AMDGPU/SIInstrInfo.h:42
 
+  typedef SmallSetVector<MachineInstr *, 32> SetVectorType;
+
----------------
A better name would indicate it's for the moveToVALU worklist. I've thought about moving all of this code into the actual pass instead of SIInstrInfo, so it doesn't really matter.


================
Comment at: test/CodeGen/AMDGPU/move-to-valu-worklist.ll:2
+; RUN: llc -march=amdgcn -mcpu=fiji -verify-machineinstrs < %s | FileCheck --check-prefix=GCN %s
+		
+; GCN-LABEL: {{^}}in_worklist_once:
----------------
Can you add a comment describing the problem 


https://reviews.llvm.org/D34726





More information about the llvm-commits mailing list