[PATCH] D34471: [Inliner] Boost inlining of an indirect call to always_inline function.
Easwaran Raman via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jun 22 10:15:27 PDT 2017
eraman added inline comments.
================
Comment at: lib/Analysis/InlineCost.cpp:978
+ if (F->hasFnAttribute(Attribute::AlwaysInline)) {
+ Cost -= InlineConstants::LastCallToStaticBonus;
+ return Base::visitCallSite(CS);
----------------
davidxl wrote:
> Maybe rename LastCallToStaticBonus more appropriately ?
I am open to suggestions. How about AlmostAlwaysInlineBonus ?
https://reviews.llvm.org/D34471
More information about the llvm-commits
mailing list