[PATCH] D33922: Apply summary-based dead stripping to regular LTO modules with summaries.
Peter Collingbourne via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jun 14 15:38:56 PDT 2017
pcc added inline comments.
================
Comment at: llvm/lib/Bitcode/Reader/BitcodeReader.cpp:5666
- return BM->hasSummary();
+ Expected<BitcodeLTOInfo> LTOInfo = BM->getLTOInfo();
+ if (!LTOInfo)
----------------
tobiasvk wrote:
> So this will be a bit misleading if you change it as you suggested in D34156 to check just for ThinLTO. Can we rename it to `hasThinLTOSummary`, or maybe even get rid of it and instead create a `getBitcodeLTOInfo(MemoryBufferRef)` function so clients can figure things out directly from the LTOInfo?
Replaced with a `getBitcodeLTOInfo` function.
https://reviews.llvm.org/D33922
More information about the llvm-commits
mailing list