[PATCH] D33291: [ThinLTO] Do not assert when adding a module with a different but compatible target triple
Mehdi AMINI via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 17 12:14:18 PDT 2017
mehdi_amini accepted this revision.
mehdi_amini added a comment.
This revision is now accepted and ready to land.
LGTM. See one inline comment.
================
Comment at: include/llvm/ADT/Triple.h:730
+ /// Test whether target triples match.
+ bool match(const Triple &Other) const;
+
----------------
`match` isn't very clear to me, I wouldn't know the difference between "match" and "equal", do you have a better name?
I'd suggest `isCompatibleWith` or something like this.
https://reviews.llvm.org/D33291
More information about the llvm-commits
mailing list