[PATCH] D33076: [PPC] Move the combine "a << (b % (sizeof(a) * 8)) -> (PPCshl a, b)" to the backend. NFC.
Eli Friedman via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 10 15:31:43 PDT 2017
efriedma added a comment.
Please update the comment in PPCISelLowering.h
================
Comment at: llvm/lib/Target/PowerPC/PPCISelLowering.cpp:13006
+ if (Mask->getZExtValue() == OpSizeInBits - 1)
+ return DAG.getNode(PPCISD::SRL, SDLoc(N), VT, N0, N1->getOperand(0));
+
----------------
Duplicated code; can you refactor these?
https://reviews.llvm.org/D33076
More information about the llvm-commits
mailing list