[PATCH] D32789: [ScopInfo] Do not use LLVM names to identify statements
Tobias Grosser via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 3 12:56:05 PDT 2017
grosser updated this revision to Diff 97714.
grosser added a comment.
- Rename option to -polly-use-llvm-names, this is sounds better and even matches
the qualcomm internal option.
- Also guard createParameterId. While this is not necessary to obtain the speedup we see, it is needed to make Polly deterministic independently if instructions are named or not.
https://reviews.llvm.org/D32789
Files:
include/polly/ScopInfo.h
include/polly/Support/GICHelper.h
lib/Analysis/ScopInfo.cpp
lib/Support/GICHelper.cpp
test/ScopInfo/unnamed_nonaffine.ll
test/ScopInfo/unnamed_stmts.ll
test/lit.site.cfg.in
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D32789.97714.patch
Type: text/x-patch
Size: 23097 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170503/652361bc/attachment.bin>
More information about the llvm-commits
mailing list