[PATCH] D32171: [ELF] - Implemented --defsym option #2

George Rimar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 19 00:43:59 PDT 2017


grimar added inline comments.


================
Comment at: test/ELF/defsym.s:16
+# CHECK-NEXT: Symbol {
+# CHECK-NEXT:   Name: foo1
+# CHECK-NEXT:   Value: [[ADDR]]
----------------
Forgot to mention this moment. We have 2 symbols 'foo1' in output here. That is because I don't
change name of alias symbol body in alias(). 
To change the name in symtab I think I need to make SymbolBody::Name public
and remove getter, that allows to set new name, but also involves changes in many places. Do we want it ? 
Aliasing itself works without that I believe.


https://reviews.llvm.org/D32171





More information about the llvm-commits mailing list