[PATCH] D31883: Don't assume PTHREAD_CREATE_JOINABLE is 0 on all systems

Francis Ricci via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Apr 11 12:53:06 PDT 2017


fjricci requested review of this revision.
fjricci added a comment.

So I think we may have to return to the original method of defining the value in the source files. `sanitizer_mac.h` is included in files that also include `pthread.h`, which causes a multiple definition error. We can't use an `ifndef`, because the pthreads header isn't necessarily included first. If we want to keep these in sanitizer_mac and sanitizer_linux, we'll need to rename them to something that won't conflict with the pthreads name. Thoughts?


https://reviews.llvm.org/D31883





More information about the llvm-commits mailing list