[PATCH] D31714: [X86] Added missing mayLoad/mayStore attributes to some X86 instructions

Craig Topper via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 5 11:15:36 PDT 2017


craig.topper added inline comments.


================
Comment at: lib/Target/X86/X86InstrVMX.td:51
+let mayStore = 1 in {
+def VMREAD64rm : I<0x78, MRMDestMem, (outs), (ins i64mem:$dst, GR64:$src),
+  "vmread{q}\t{$src, $dst|$dst, $src}", []>, PS, Requires<[In64BitMode]>;
----------------
Do you mind changing the name of these to VMREAD64mr and VMREAD32mr as a NFC pre-patch. That would be more consistent with our other instruction names.


https://reviews.llvm.org/D31714





More information about the llvm-commits mailing list