[PATCH] D31299: Move spill size and alignment info from MC to TargetRegisterInfo
Matthias Braun via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Mar 23 14:00:46 PDT 2017
MatzeB accepted this revision.
MatzeB added a comment.
This revision is now accepted and ready to land.
Makes sense.
================
Comment at: include/llvm/Target/TargetRegisterInfo.h:98
/// of a stack slot allocated to hold a spilled copy of this register.
- unsigned getSize() const { return MC->getSize(); }
+ unsigned getSize() const { return SpillSize; }
----------------
How hard would it be to rename this to getSpillSize() to avoid confusing?
We can however do that in a separate patch.
Repository:
rL LLVM
https://reviews.llvm.org/D31299
More information about the llvm-commits
mailing list