[PATCH] D31255: Force @{init, fini}_array if section name starts with ".{init, fini}_array.".

Gustaw Smolarczyk via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 22 15:47:50 PDT 2017


gsmolarczyk added inline comments.


================
Comment at: lld/ELF/InputSection.cpp:88
+  if (Type == SHT_PROGBITS && Name.startswith(".fini_array."))
+    return SHT_FINI_ARRAY;
+  return Type;
----------------
ruiu wrote:
> gsmolarczyk wrote:
> > How about folding if (Type == SHT_PROGBITS) into outer if instruction?
> I originally did this that way, but I changed that as I think this new code is slightly easier to read.
You might be right. Ok with me either way.


https://reviews.llvm.org/D31255





More information about the llvm-commits mailing list