[PATCH] D29847: [LV] Extend trunc optimization to all IVs with constant integer steps

Matthew Simpson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Feb 14 06:40:30 PST 2017


mssimpso added inline comments.


================
Comment at: lib/Transforms/Vectorize/LoopVectorize.cpp:2037
+    Value *Op = Trunc->getOperand(0);
+    if (Op != Legal->getInduction() && TTI.isTruncateFree(SrcTy, DestTy))
+      return false;
----------------
mkuper wrote:
> Unrelated, but after this lands, I think I'll change the name to getPrimaryInduction() or getPrimaryIV(). This is a really bad name at this point.
> 
I agree. Thanks Michael.


https://reviews.llvm.org/D29847





More information about the llvm-commits mailing list