[PATCH] D28637: [PPC] Inline expansion of memcmp

Lei Huang via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Feb 7 06:48:51 PST 2017


lei added inline comments.


================
Comment at: lib/CodeGen/CodeGenPrepare.cpp:2145
+
+  // Find the first load size that is less than remainder
+  while (CurrLoadSize > Remainder)
----------------
It would be more meaningful to put something like .... find the max load size that can be used


================
Comment at: lib/CodeGen/CodeGenPrepare.cpp:2150
+  // Continue to create load compare blocks until we no longer have a remainder
+  while (Remainder) {
+    // Calculate how many blocks can we create with the current load size
----------------
We should find a better name for this "Remainder" variable.  I find it confusing.  It should be named for what it actually is, which see to be the number of bytes to be processed.  Maybe something like NumBytesToBeProcessed.


https://reviews.llvm.org/D28637





More information about the llvm-commits mailing list