[PATCH] D28897: [PM] Simplify the new PM interface to the loop unroller and expose two factory functions for the two modes the loop unroller is actually used in in-tree: simplified full-unrolling and the entire thing including partial unrolling.
Davide Italiano via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jan 24 07:43:34 PST 2017
davide added a comment.
In https://reviews.llvm.org/D28897#654715, @chandlerc wrote:
> In https://reviews.llvm.org/D28897#654378, @davide wrote:
>
> > I have a fundamental question about the constructors.
>
>
> See updated patch! =D
>
> > Also, I would prefer the spelling `FullUnroll` instead of `SimpleUnroll`.
>
> Not sure what you actually want yet...
>
> Currently we have `LoopUnrollPass::create()` and `LoopUnrollPass::createSimple()`, and at the pipeline `unroll` and `unroll-simple`. Are you suggesting just using "full" instead of "simple" with the same structure? `unroll-full` makes sense, but `LoopUnrollPass::createFull()` seems weird. It is a less powerful pass...
I was suggesting `unroll-full` for the name of the pass (and what you pass to opt, or whatever. I agree with you `createFull` and `createSimple` can stay as they are (sorry if it wasn't entirely clear to begin with)
https://reviews.llvm.org/D28897
More information about the llvm-commits
mailing list