[PATCH] D28991: [lld] Use %u instead of %d for uint32_t formatting
Hugh Bellamy via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun Jan 22 11:43:27 PST 2017
hughbe updated this revision to Diff 85292.
https://reviews.llvm.org/D28991
Files:
trunk/COFF/Writer.cpp
Index: trunk/COFF/Writer.cpp
===================================================================
--- trunk/COFF/Writer.cpp
+++ trunk/COFF/Writer.cpp
@@ -205,7 +205,7 @@
*Hdr = Header;
if (StringTableOff) {
// If name is too long, write offset into the string table as a name.
- sprintf(Hdr->Name, "/%d", StringTableOff);
+ sprintf(Hdr->Name, "/%u", StringTableOff);
} else {
assert(!Config->Debug || Name.size() <= COFF::NameSize);
strncpy(Hdr->Name, Name.data(),
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D28991.85292.patch
Type: text/x-patch
Size: 494 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170122/a24f8e78/attachment.bin>
More information about the llvm-commits
mailing list