[PATCH] D24510: [mips] Correct c.cond.fmt instruction definition.

Vasileios Kalintiris via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jan 11 04:42:49 PST 2017


vkalintiris accepted this revision.
vkalintiris added a comment.
This revision is now accepted and ready to land.

LGTM.



================
Comment at: lib/Target/Mips/AsmParser/MipsAsmParser.cpp:4137-4138
+  uint64_t TSFlags = getInstDesc(Inst.getOpcode()).TSFlags;
+  if (TSFlags & MipsII::HasFCCRegOperand &&
+      Inst.getOperand(0).getReg() != Mips::FCC0 && !hasEightFccRegisters())
+    return Match_NoFCCRegisterForCurrentISA;
----------------
Parenthesizing the sub-expressions would make this a little bit easier to read.


================
Comment at: lib/Target/Mips/MicroMipsInstrFPU.td:31
+                  CEQS_FM_MM<0> {
+  // FIXME: This is a required to work around the fact that thiese instructions
+  //        only use $fcc0. Ideally, MipsFPCmp nodes could be removed and the
----------------
s/thiese/these/, similarly below.


================
Comment at: lib/Target/Mips/MipsInstrFPU.td:620
+
+  // FIXME: This is a required to work around the fact that thiese instructions
+  //        only use $fcc0. Ideally, MipsFPCmp nodes could be removed and the
----------------
s/thiese/these/, similarly below.


https://reviews.llvm.org/D24510





More information about the llvm-commits mailing list