[PATCH] D28460: getLoopEstimatedTripCount should really be called getLoopEstimatedBackedgeTakeCount.

Xin Tong via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jan 9 10:28:06 PST 2017


trentxintong added a comment.

In https://reviews.llvm.org/D28460#639880, @danielcdh wrote:

> What's the motivation of this change?
>
> Thanks,
> Dehao


The getLoopEstimatedTripCount function is really returning the backedge taken count. Trip count == backedge taken count + 1. So I rename it in this patch. The place I am not sure is whether you were looking for backedge count or trip count in LoopUnrollPass.cpp. It seems that you were assigning a profiled backedge count to ProfileTripCount variable.


https://reviews.llvm.org/D28460





More information about the llvm-commits mailing list