[PATCH] D27577: [libFuzzer] Diff 18 - Avoid name collision with Windows API.

Adrian McCarthy via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 8 10:06:20 PST 2016


amccarth added a comment.

I won't object to this change, but, in my experience, the `#undef` approach is better.  It doesn't force you to compromise your API design, and it keeps the Windows-specific fixes local to the Windows-specific code.

If we were to `#undef DeleteFile` and later wanted to call the actual WinAPI DeleteFile, we'd just have to use the actual function name, either DeleteFileW or DeleteFileA, which modern code should be doing anyway.


Repository:
  rL LLVM

https://reviews.llvm.org/D27577





More information about the llvm-commits mailing list