[PATCH] D26595: IR: Change PointerType to derive from Type rather than SequentialType.
Peter Collingbourne via llvm-commits
llvm-commits at lists.llvm.org
Thu Nov 24 21:12:48 PST 2016
pcc marked an inline comment as done.
pcc added inline comments.
================
Comment at: llvm/include/llvm/IR/DerivedTypes.h:316
Type *ContainedType; ///< Storage for the single contained type.
+ uint64_t NumElements;
SequentialType(const SequentialType &) = delete;
----------------
dblaikie wrote:
> Might be best to save the refactoring here for a separate patch - make things a bit easier to follow (ie: which bit makes PointerType not a SequentialType, and then which things are improvements now that all SequentialTypes have numElements, etc).
>
> Maybe. Open to debate/discussion/disagreement for sure.
Seems reasonable enough. Done: : D27122
https://reviews.llvm.org/D26595
More information about the llvm-commits
mailing list