[PATCH] D26567: Improve DWARF parsing speed by improving DWARFAbbreviationDeclaration
Adrian Prantl via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 14 16:43:40 PST 2016
aprantl accepted this revision.
aprantl added a comment.
This revision is now accepted and ready to land.
Thanks!
================
Comment at: lib/DebugInfo/DWARF/DWARFAbbreviationDeclaration.cpp:192
+ return ByteSize;
+ return DWARFFormValue::getFixedByteSize(Form, &U);
+}
----------------
clayborg wrote:
> aprantl wrote:
> > Maybe it's easier to read to have this as a ?: one-liner inlined the class declaration?
> Not sure I follow? Do you want this?:
>
> ```
> return ByteSize ? ByteSize : DWARFFormValue::getFixedByteSize(Form, &U);
> ```
Yes. This is up to taste — but since this is just a very straightforward single line it might be a better to just move it straight into the class definition.
https://reviews.llvm.org/D26567
More information about the llvm-commits
mailing list