[PATCH] D23252: [ADT] Zip range adapter
Zachary Turner via llvm-commits
llvm-commits at lists.llvm.org
Fri Sep 30 10:14:18 PDT 2016
zturner added a comment.
What is the status of this? I ended up writing my own zip implementation (see https://reviews.llvm.org/D25109) before it was pointed out to me that this already exists, but I see there has been no activity in some time.
It looks like this is waiting for comments from chandlerc@ and rsmith@?
> bryant wrote in STLExtras.h:245
> according to http://en.cppreference.com/w/cpp/utility/integer_sequence it's c++14, whereas i'm aiming for c++11.
yes but we have `llvm::integer_sequence` in this very file. Can we use that instead?
> STLExtras.h:251
> +
> +template <typename... Iters> class ZipFirst {
> +public:
For STL-like classes and functions, I believe we prefer to follow STL naming conventions. So I would imagine this should be `zip_first`
Repository:
rL LLVM
https://reviews.llvm.org/D23252
More information about the llvm-commits
mailing list