[PATCH] D24370: Add support for writing TPI hash values

Reid Kleckner via llvm-commits llvm-commits at lists.llvm.org
Wed Sep 14 11:04:11 PDT 2016


rnk added inline comments.

================
Comment at: include/llvm/DebugInfo/PDB/Raw/TpiRecordHashVisitor.h:24
@@ +23,3 @@
+namespace pdb {
+class TpiRecordHashUpdateVisitor : public codeview::TypeVisitorCallbacks {
+public:
----------------
Five words in a class name feels like too much. At least, it's not consistent with the rest of LLVM. How do these names sound?
TpiHashing.h
TpiHashUpdater
TpiHashVerifier

The first class computes the hash, the second one verifies an existing hash.

I don't feel like `Record` or `Visitor` are helping readability that much.

================
Comment at: lib/DebugInfo/PDB/Raw/TpiRecordHashVisitor.cpp:44
@@ +43,3 @@
+
+template <typename T> static uint32_t getSouceLineHash(T &Rec) {
+  char Buf[4];
----------------
Typo on "Souce"


https://reviews.llvm.org/D24370





More information about the llvm-commits mailing list