[PATCH] D23225: [ADCE] Modify data structures to support removing control flow
David Callahan via llvm-commits
llvm-commits at lists.llvm.org
Fri Aug 5 15:17:38 PDT 2016
david2050 marked an inline comment as done.
================
Comment at: lib/Transforms/Scalar/ADCE.cpp:150
@@ +149,3 @@
+ // structure to twice that size to keep the load factor low in the hash table.
+ BlockInfo.grow(2 * NumBlocks);
+ auto InfoP = BlockInfoVec.begin();
----------------
Missed this the first pass, in next diff
================
Comment at: lib/Transforms/Scalar/ADCE.cpp:261
@@ +260,3 @@
+ // TODO -- handle PhiNodes
+ } while (!Worklist.empty());
+
----------------
Will rename function to make this more explicit
https://reviews.llvm.org/D23225
More information about the llvm-commits
mailing list