[PATCH] D23018: [sanitizer] Implement a __asan_default_options() equivalent for Scudo

Kostya Kortchinsky via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 1 09:16:44 PDT 2016


cryptoad created this revision.
cryptoad added reviewers: kcc, llvm-commits.

Currently, the Scudo Hardened Allocator only gets its flags via the SCUDO_OPTIONS environment variable.
With this patch, we offer the opportunity for programs to define their own options via getScudoDefaultOptions() which behaves like __asan_default_options() (weak symbol).
A relevant test has been added as well.
I also used this patch as an opportunity to rename a few variables to comply with the LLVM naming scheme.

https://reviews.llvm.org/D23018

Files:
  projects/compiler-rt/lib/scudo/scudo_allocator.cpp
  projects/compiler-rt/lib/scudo/scudo_flags.cpp
  projects/compiler-rt/test/scudo/options.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D23018.66331.patch
Type: text/x-patch
Size: 3288 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160801/80257759/attachment.bin>


More information about the llvm-commits mailing list