[PATCH] D21612: [compiler-rt] [XRay] Basic initialization and flag definition for XRay runtime

Reid Kleckner via llvm-commits llvm-commits at lists.llvm.org
Tue Jul 26 13:00:51 PDT 2016


rnk added inline comments.

================
Comment at: compiler-rt/trunk/lib/xray/xray_trampoline_x86.S:90
@@ +89,3 @@
+	popq	%rbp
+	retq
+.Ltmp3:
----------------
rSerge wrote:
> Shouldn't it be RETL for x86 and RETQ for x86_64 ? The original instruction in the compile-time sled could be RETL (then we should do RETL too) or RETQ (then we should do RETQ too), I think.
This is definitely x86_64 only code. Perhaps this file should be renamed xray_trampoline_x86_64.S


Repository:
  rL LLVM

https://reviews.llvm.org/D21612





More information about the llvm-commits mailing list