[PATCH] D22519: Invariant start/end intrinsics overloaded for address space

Artur Pilipenko via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 21 08:57:28 PDT 2016


apilipenko accepted this revision.
apilipenko added a comment.
This revision is now accepted and ready to land.

LGTM


================
Comment at: lib/IR/AutoUpgrade.cpp:154
@@ +153,3 @@
+      auto Args = F->getFunctionType()->params();
+      auto ObjectPtr = Args[1];
+      if (F->getName() !=
----------------
It's a Type not a Value, right? That's not obvious. I'd name it accordingly or/and use the type instead of auto.  


https://reviews.llvm.org/D22519





More information about the llvm-commits mailing list