[PATCH] D22617: [ELF] - Linkerscript: add InputSectionDescription command to LS parser.

George Rimar via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 21 05:28:02 PDT 2016


grimar added inline comments.

================
Comment at: ELF/LinkerScript.cpp:247
@@ +246,3 @@
+  for (const std::unique_ptr<BaseCommand> &Base : Opt.Commands)
+    if (auto *OutSec = dyn_cast<OutputSectionCommand>(Base.get()))
+      for (const std::unique_ptr<BaseCommand> &Cmd : OutSec->Commands)
----------------
grimar wrote:
> ruiu wrote:
> > `OutSec` as a name for a command is very confusing.
> Changed to OutSec.
I mean to OutCmd, sorry.


https://reviews.llvm.org/D22617





More information about the llvm-commits mailing list