[PATCH] D21995: [ELF] Implement minimal PHDRS parser and section-to-segment assignment
Hector David via llvm-commits
llvm-commits at lists.llvm.org
Mon Jul 18 20:44:15 PDT 2016
Hektve87 added a comment.
(~~~~)
================
Comment at: ELF/LinkerScript.cpp:290
@@ +289,3 @@
+
+ for (const PhdrsCommand &Hdr : Opt.PhdrsCommands) {
+ Phdrs.emplace_back(Hdr.HeaderType, PF_R);
----------------
ruiu wrote:
> Again, it is hard to read if you call both ELF program headers and linker script's PHDRS command "headers". Rename Hdr -> Cmd.
(~~~~)
https://reviews.llvm.org/D21995
More information about the llvm-commits
mailing list