[PATCH] D22249: Get rid of bool parameters in SelectionDAG::getLoad, getStore, and friends.
Justin Lebar via llvm-commits
llvm-commits at lists.llvm.org
Mon Jul 11 18:31:03 PDT 2016
jlebar added inline comments.
================
Comment at: lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp:3658-3662
@@ -3658,2 +3657,7 @@
unsigned Alignment = I.getAlignment();
+ const unsigned MMOFlags =
+ (I.isVolatile() ? MachineMemOperand::MOVolatile : 0) |
+ (I.getMetadata(LLVMContext::MD_nontemporal) != nullptr
+ ? MachineMemOperand::MONonTemporal
+ : 0);
SDLoc dl = getCurSDLoc();
----------------
chandlerc wrote:
> I think separate statements with |= would be easier to read here than the big expression.
Does your evaluation change if I told you that we need a static_cast around every bitwise operation on our enum?
http://reviews.llvm.org/D22249
More information about the llvm-commits
mailing list