[PATCH] D22186: [SCCP] Add support for insertelement instructions
Davide Italiano via llvm-commits
llvm-commits at lists.llvm.org
Sat Jul 9 15:57:59 PDT 2016
davide added a comment.
In http://reviews.llvm.org/D22186#479404, @davide wrote:
> In http://reviews.llvm.org/D22186#479403, @eli.friedman wrote:
>
> > I think you're misunderstanding what "isUndefined" means... it means "we haven't computed the value of this instruction yet", not "this value is an UndefValue". See https://www.cs.rice.edu/~keith/512/2011/Lectures/L19-SCCP-1up.pdf and http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.105.4146&rep=rep1&type=pdf .
>
>
> Yes, I was confused.. the code actually in some places uses isUndefined() as synonim to undef which now I see why it's completely wrong... I'd like to rename isUndefined() to isUnknown(), which is what Keith Cooper uses in the slides, what do you think?
In http://reviews.llvm.org/D22186#479414, @eli.friedman wrote:
> Sure, that's fine (in a separate commit, of course).
I also went forward and removed all the dead vector code `b38095fbc8454f96e9d4ff88db28769cba741f71` which used `isUndefined()` wrongly
http://reviews.llvm.org/D22186
More information about the llvm-commits
mailing list