[PATCH] D22015: [ELF] Introduce a flag to parse response file according to windows rules
Rui Ueyama via llvm-commits
llvm-commits at lists.llvm.org
Wed Jul 6 13:02:04 PDT 2016
ruiu added inline comments.
================
Comment at: ELF/DriverUtils.cpp:59
@@ -57,1 +58,3 @@
+ StringRef RspQuoting;
+ for (const char *F : Argv)
----------------
Move new code to a new function, say `getQuoteStyle`, to keep this function concise.
I think we want to handle edge cases such as single quote and double quotes or with/without '='. But I think we don't want to handle that by hand. So, how about calling this->Parse twice; once for --rsp-quoting and the other for all other options.
http://reviews.llvm.org/D22015
More information about the llvm-commits
mailing list