[PATCH] D19501: Add LoadStoreVectorizer pass

Alina Sbirlea via llvm-commits llvm-commits at lists.llvm.org
Fri Jun 17 15:20:36 PDT 2016


asbirlea added inline comments.

================
Comment at: lib/Transforms/Vectorize/LoadStoreVectorizer.cpp:288
@@ +287,3 @@
+  for (User *U : I->users())
+    if (Instruction *User = dyn_cast<Instruction>(U))
+      if (!DT.dominates(I, User) && User->getOpcode() != Instruction::PHI) {
----------------
Nit: Could the Instruction instance "User" be renamed to something different than a class name? It makes it somewhat harder to follow.


http://reviews.llvm.org/D19501





More information about the llvm-commits mailing list