[PATCH] D21232: Add attribute noreturn to functions that throw
Aditya Kumar via llvm-commits
llvm-commits at lists.llvm.org
Thu Jun 16 11:32:05 PDT 2016
hiraditya added a comment.
In http://reviews.llvm.org/D21232#459779, @mclow.lists wrote:
> This looks much better, but the macro name is misleading. The routines are not "always noreturn", they're "noreturn in some circumstances" - specifically when exceptions are disabled.
>
> That's why I suggested "something like `LIBCPP_NORETURN_IF_NO_EXCEPTIONS`", and I still think that's a good idea.
> I'm not going to insist on that name, but something more descriptive than `_LIBCPP_ATTR_NORETURN`, please.
Will do that
In http://reviews.llvm.org/D21232#459779, @mclow.lists wrote:
> This looks much better, but the macro name is misleading. The routines are not "always noreturn", they're "noreturn in some circumstances" - specifically when exceptions are disabled.
>
> That's why I suggested "something like `LIBCPP_NORETURN_IF_NO_EXCEPTIONS`", and I still think that's a good idea.
> I'm not going to insist on that name, but something more descriptive than `_LIBCPP_ATTR_NORETURN`, please.
Thanks for the suggestion, I agree LIBCPP_NORETURN_IF_NO_EXCEPTIONS makes more sense.
http://reviews.llvm.org/D21232
More information about the llvm-commits
mailing list