[PATCH] D21232: Add attribute noreturn to functions that throw

Marshall Clow via llvm-commits llvm-commits at lists.llvm.org
Thu Jun 16 06:38:18 PDT 2016


mclow.lists added a comment.

This looks much better, but the macro name is misleading. The routines are not "always noreturn", they're "noreturn in some circumstances" - specifically when exceptions are disabled.

That's why I suggested "something like `LIBCPP_NORETURN_IF_NO_EXCEPTIONS`", and I still think that's a good idea.
I'm not going to insist on that name, but something more descriptive than `_LIBCPP_ATTR_NORETURN`, please.


http://reviews.llvm.org/D21232





More information about the llvm-commits mailing list