[PATCH] D20560: [new PM] port LoopAccessAnalysis to new pass manager (part-1)
Adam Nemet via llvm-commits
llvm-commits at lists.llvm.org
Wed Jun 8 03:24:19 PDT 2016
anemet accepted this revision.
anemet added a reviewer: anemet.
anemet added a comment.
This revision is now accepted and ready to land.
I am fine with this with comments below addressed. Thanks!
================
Comment at: include/llvm/Analysis/LoopAccessAnalysis.h:677
@@ -676,1 +676,3 @@
+class LoopAccessFuncInfo {
+public:
----------------
This needs a class comment. Also what do you think about naming this Result as well, i.e. LoopAccessAnalysisResult?
================
Comment at: include/llvm/Analysis/LoopAccessAnalysis.h:679-680
@@ +678,4 @@
+public:
+ LoopAccessFuncInfo()
+ : LoopAccessInfoMap(), AA(nullptr), DT(nullptr), LI(nullptr),
+ SCEV(nullptr), TLI(nullptr) {}
----------------
You don't need to call the default ctor for LAIM like this. Also you may want to use in-class data member initializers for the nullptrs and then remove the ctor altogether.
http://reviews.llvm.org/D20560
More information about the llvm-commits
mailing list