[PATCH] D20331: [llvm-mc] - Teach llvm-mc to generate compressed debug sections in zlib style.

Davide Italiano via llvm-commits llvm-commits at lists.llvm.org
Wed May 18 08:11:51 PDT 2016


davide added inline comments.

================
Comment at: lib/MC/ELFObjectWriter.cpp:576
@@ -575,4 +575,3 @@
   auto &Sec = cast<MCSectionELF>(Sym->getSection());
-  unsigned Flags = Sec.getFlags();
-  if (Flags & ELF::SHF_MERGE) {
+  if (Sec.Flags & ELF::SHF_MERGE) {
     if (C != 0)
----------------
grimar wrote:
> davide wrote:
> > You can change that separately, if you really like. It's unrelated, and makes the patch slightly less readable.
> Please see my comment below.
I can review them at the same time but they should be committed separately.

================
Comment at: lib/MC/ELFObjectWriter.cpp:1024
@@ +1023,3 @@
+    // Write Elf64_Chdr header.
+    write((ELF::Elf64_Word)ELF::ELFCOMPRESS_ZLIB);
+    write((ELF::Elf64_Word)0); // ch_reserved field.
----------------
static_cast<> instead of C-style cast?


http://reviews.llvm.org/D20331





More information about the llvm-commits mailing list