[PATCH] D19664: [MemorySSA] Port to new pass manager

Daniel Berlin via llvm-commits llvm-commits at lists.llvm.org
Wed May 4 13:02:42 PDT 2016


On Wed, May 4, 2016 at 12:43 PM, George Burgess IV <
george.burgess.iv at gmail.com> wrote:

> > I'm not convinced this is the right model in the new pass manager - it's
> > essentially giving us two layers of caching, since the new PM already
> > computes the analysis on demand (when you first call getResult) and
> > caches that until its invalidated.
>
> IIRC, the lazy pass was made before we decided to just compute everything
> eagerly all the time (which lets us provide the
> uses-point-to-their-actual-clobbering-defs guarantee). So, the name here is
> somewhat misleading. If it turns out that we don't need this at all, I
> think it would be fine to remove it. Otherwise, renaming it to just
> MemorySSAPass (or similar) would probably be best.
>




>
> > This is pretty weird in a printer pass. Does this mean we would need to
> > call buildMemorySSA in *any* user of the analysis pass?
>
> Yeah, the API is a bit ugly here. :)
>

This is because it was originally a utility and not a pass :)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160504/5a469909/attachment.html>


More information about the llvm-commits mailing list